フォーラム

トピックを立てる前にチェック
  1. フォーラムガイドライン」に必ず目を通してください。
  2. バージョンアップデート後に表示がおかしくなった場合は、
    「SWELL設定」>「リセット」からキャッシュクリアを先にお試しください。
  3. フォーラム内検索で過去に同じようなトピックがないか検索してみてください。
ブログパーツをトップメインビジュアル内...
 
通知
すべてクリア

ブログパーツをトップメインビジュアル内に表示

WR
 WR
(@wr)
メンバー

お世話になっております

ブログパーツに「検索ボックス」を設定。

カスタマイザーからそのパーツIDをメインビジュアル内に設定。

しかし表示されません。

ブログパーツの種類によって、メインビジュアル内には表示できるものとできないものがあるのでしょうか?

サイトURLは契約の関係上、BASIC認証をかけているためお見せすることができません。

お手数をおかけしますが、よろしくお願いいたします。

別件
不具合報告では、スマホのブラウザが「プライベートモードになっていた」のが原因のようでした。
解決しました。お騒がせしました。

確認項目
利用規約に同意します*, ガイドラインを読み、内容を把握しています*, よくある質問を先にチェック済みです*, 過去に同じようなトピックがないか検索済みです*, Googleなどでも検索してみました, プラグインを停止しても同じことが起こることを確認しました, 自分で追加したコードに問題がないかチェック済みです
問題が確認できるページのURL
利用中のSWELL本体のバージョン
最新
利用中のPHPバージョン
7.4系
OS
WIn10・Mac
利用中のWordPressバージョン
最新
利用中のサーバー会社
Xサーバー
ブラウザ
Chrome
利用中のプラグイン一覧

マルチバイト

引用
Topic starter 投稿済 : 21/11/2021 1:30 am
しらこ
(@96ssbike)
メンバー

どういう状況かわかりませんが、ショートコード全体をコピペしたりしていませんか?(IDのみを抜き出して記述します)

サイトURLが貼れない場合は、具体的にどういう手順で貼ったかを詳しく共有をお願いいたします。もしくはできるだけ差し支えない範囲で設定画面などの画像を多く材料貼り付けて、こちらが内容を把握できるようにしてください。

また、別件の連絡は別件のほうへ報告の書き込みをお願いいたします。(こちらがどの内容に対する返信か見に行く工数が生じます。また、ぱっと見どれに対しての返信か不明です)

This post was modified 2か月前 3回 by しらこ

SWELLカスタマイズ向けの非公式サイトを作りました。何か見つかるかも?→ https://tecchan.jp/swell-tips/
上記以外のWordPress全般向けのナレッジはこちら→ https://tecchan.jp/
疲れたら癒やされてくださいにゃーん (ΦωΦ)

返信引用
投稿済 : 21/11/2021 1:37 am
momo 件のいいね!
WR
 WR
(@wr)
メンバー

検索ボックス以外にも、画像ですらメインビジュアル上にはブログパーツを表示できませんでした。

メインビジュアル以外ではブログパーツは表示されています。

メインビジュアルはIDのみを打ち込む仕様ですが、この仕様がBASIC認証と干渉している等、原因として考えられるものですか?

他にもメインビジュアルのフェードやスライドは動きますが、ズームと右にゆっくり移動する部分も動きません。

Devツールでは以下のエラーが出ています。

DevTools failed to load source map: Could not load content for chrome-extension://eakacpaijcpapndcfffdgphdiccmpknp/scripts/content_page.map: HTTP error: status code 404, net::ERR_UNKNOWN_URL_SCHEME
DevTools failed to load source map: Could not load content for https://example.com/wp-content/themes/swell/assets/js/plugins/swiper-bundle.min.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

何度もお手数をおかけしますが、よろしくお願いいたします。

返信引用
Topic starter 投稿済 : 21/11/2021 1:47 am
WR
 WR
(@wr)
メンバー

@96ssbike 

ご返信ありがとうございます。
IDのみ半角数字で入力しています。

SWELLは頻繁に使用しているので、他のサイトではブログパーツは正常です。
BASIC認証をかけていないサイトで、メインビジュアルに検索ボックスが表示できるか試してみます。

別件
別件の方はスレッドが「完了」とされており書き込みできませんでした。申し訳ございません。

This post was modified 2か月前 by WR
返信引用
Topic starter 投稿済 : 21/11/2021 1:51 am
しらこ
(@96ssbike)
メンバー

@wr 完了でも書き込みできますよ。もし書き込む部分が表示されなければ、そのページでリロードをお試しください。

SWELLカスタマイズ向けの非公式サイトを作りました。何か見つかるかも?→ https://tecchan.jp/swell-tips/
上記以外のWordPress全般向けのナレッジはこちら→ https://tecchan.jp/
疲れたら癒やされてくださいにゃーん (ΦωΦ)

返信引用
投稿済 : 21/11/2021 1:54 am
しらこ
(@96ssbike)
メンバー

また、いただいたうちの「ブログパーツ」が表示されない現象が判明しました。

外観 > カスタマイズ> トップページ > メインビジュアル > 「スライド1枚目のテキストを常に表示する」を有効にすると、いただいた現象が再現できました。

これが仕様なのか不具合なのかは @loos_ryo さんに確認していただき、現状での回避策は、複数のメインビジュアルに対してすべて同一のテキスト・同一のブログパーツを挿入することでしょうか。

This post was modified 2か月前 2回 by しらこ

SWELLカスタマイズ向けの非公式サイトを作りました。何か見つかるかも?→ https://tecchan.jp/swell-tips/
上記以外のWordPress全般向けのナレッジはこちら→ https://tecchan.jp/
疲れたら癒やされてくださいにゃーん (ΦωΦ)

返信引用
投稿済 : 21/11/2021 1:57 am
WR
 WR
(@wr)
メンバー

@96ssbike 

返信しようとすると「ログインまたは登録してください」と繰り返し表示され書き込みできませんでした。
ここには書き込みできているのですが・・・。

返信引用
Topic starter 投稿済 : 21/11/2021 2:01 am
WR
 WR
(@wr)
メンバー

@96ssbike 

「スライド1枚目のテキストを常に表示する」のチェックを外すと検索ボックスがでました!

ですが、2枚目以降だと消えてしまうので、それぞれ設定してみます。

ありがとうございました!!

This post was modified 2か月前 by WR
返信引用
Topic starter 投稿済 : 21/11/2021 2:02 am
WR
 WR
(@wr)
メンバー

検索ボックスが透明で枠線も薄くビジュアル上に配置するには不向きっぽいのでCSSで調整しようと思いますが、もし「スライド1枚目のテキストを常に表示する」と検索ボックスのブログパーツが併用できそうであれば、修正をご検討いただけますと幸いです。

ありがとうございました。

This post was modified 2か月前 3回 by WR
返信引用
Topic starter 投稿済 : 21/11/2021 2:25 am
共有: