2022年10月9日、SWELLの利用規約を改訂しました。

フォーラム

トピックを立てる前にチェック
  1. フォーラムガイドライン」に必ず目を通してください。
  2. バージョンアップデート後に表示がおかしくなった場合は、
    「SWELL設定」>「リセット」からキャッシュクリアを先にお試しください。
  3. フォーラム内検索で過去に同じようなトピックがないか検索してみてください。
「このブロックでエラーが発生したためプ...
 
通知
すべてクリア

[解決済] 「このブロックでエラーが発生したためプレビューできません。」が表示される

5 投稿
3 ユーザー
1 Likes
139 表示
ryusuke0115
(@ryusuke0115)
投稿: 3
メンバー
Topic starter
 

先週SWELLを購入したブログ初心者です。

SWELL購入後サイトを立ち上げ、今日から記事を書こうとしたところ、トラブルが起こってしまいました。

投稿記事内のブロック内に文章を打つことが出来るのですが、マウスで違うブロックをクリックしたりすると
「このブロックでエラーが発生したためプレビューできません。」
と表示されるようになってしまいました。

GoogleやTwitter、過去の質問などを調べると同様のエラーの事例があり、そのほとんどはWordpressやSWELLのバージョンを最新のものに更新することで解消されているようですが、自分の場合は既に最新のバージョンになっているにもかかわらずエラーがでてしまっています。

また、プラグインが原因ではないかとも考え、全て無効にもしてみたものの、やはり同様のエラーが起きてしまいます。

CSSに関しては追加はしていません。

ちなみにですが、固定ページでは同様のエラーは見受けられていません。

原因と解消方法を教えていただきたく、投稿させていただきました。

よろしくお願いいたします。

 

 

 

確認項目
利用規約に同意します*, ガイドラインを読み、内容を把握しています*, よくある質問を先にチェック済みです*, 過去に同じようなトピックがないか検索済みです*, WordPress更新後、SWELLは最新版にしましたか?, Googleなどでも検索してみました, プラグインを停止しても同じことが起こることを確認しました, デフォルトテーマ等、他のテーマでも同じことが起こることを確認しました, 自分で追加したコードに問題がないかチェック済みです, サポート範囲外だということを理解しているが助けが欲しい(有料サポートしてくれる方を探したい)
問題が確認できるページのURL
利用中のSWELL本体のバージョン
2.6.9.4
利用中のPHPバージョン
7.4.29
OS
Windows
利用中のWordPressバージョン
6.0.2
利用中のサーバー会社
ConoHa
ブラウザ
Firefox
利用中のプラグイン一覧

All-in-One WP Migration (v.7.66)
ConoHa WING 自動キャッシュクリア (v.1.0.0)
EWWW Image Optimizer (v.6.9.1)
SEO SIMPLE PACK (v.3.0.0)
Throws SPAM Away (v.3.4.6)
TypeSquare Webfonts for ConoHa (v.2.0.3)
Wordfence Security (v.7.7.1)
WordPress Ping Optimizer (v.2.35.1.3.0)
WPForms Lite (v.1.7.7.2)
WP Multibyte Patch (v.2.9)
WP Sitemap Page (v.1.9.1)
XML Sitemap & Google News (v.5.3.3)

 
投稿済 : 17/10/2022 8:28 pm
しらこ
(@96ssbike)
投稿: 539
メンバー
 

できれば発生している状況を動画でスクリーンショットを撮っていただけると、なにか具体的なことがわかるかもしれません。

SWELLカスタマイズ向けの非公式サイトを作りました。何か見つかるかも?→ https://tecchan.jp/swell-tips/
上記以外のWordPress全般向けのナレッジはこちら→ https://tecchan.jp/
疲れたら癒やされてくださいにゃーん (ΦωΦ)

 
投稿済 : 22/10/2022 8:58 pm
ryusuke0115
(@ryusuke0115)
投稿: 3
メンバー
Topic starter
 

コメントありがとうございます。

スクリーンショット動画を添付してみましたが、見れるでしょうか?

ブロックをクリックするとエラーが出る状態です。

補足ですがプラグインの「EWWW Image Optimizer」はSWELLと相性が悪いということで削除致しましたが、改善されませんでした。

サーバーに問題があるかなと思い、ConoHa WINGではなく新たにサクラサーバーに申込みし、別サイトを立ち上げてSWELLを導入しましたが、同じ状態になってしまいました。こちらの方は諦めてcocoonを導入しましたが、cocoonではその様な症状は起きておりません。

 

 
投稿済 : 24/10/2022 8:41 pm
了
 
(@loos_ryo)
投稿: 902
メンバー Admin
 

んー、見たことがない現象ですね。固定ページでは問題がないというのも不思議です。

プラグインか何かの影響を受けているか、サーバー側のキャッシュ機能が原因かもしれません。

ちなみにFirefoxをお使いのようですが、Chromeだとどうですか?

SWELL開発者です。

 
投稿済 : 25/10/2022 3:54 pm
ryusuke0115
(@ryusuke0115)
投稿: 3
メンバー
Topic starter
 

コメントありがとうございます。

Chromeで試したところ、同様の現象は起こりませんでした。

どうやらFirefoxが良くなかったようです。

ブラウザを疑わなかった初歩的なミスをしてしまいました。

補足ですが、Firefoxの使用でもサイドバー(ブックマーク等)を閉じるとなぜかエラーが起きないことも新たに把握いたしました。

なんであれ、SWELLを使うことができそうで、本当に良かったです。

助言していただいた方々、本当にありがとうございました。

 

 
投稿済 : 25/10/2022 10:09 pm
reacted
共有: