Discordコミュニティを作りました! 参加する

フォーラム

トピックを立てる前にチェック
  1. フォーラムガイドライン」に必ず目を通してください。
  2. バージョンアップデート後に表示がおかしくなった場合は、
    「SWELL設定」>「リセット」からキャッシュクリアを先にお試しください。
  3. フォーラム内検索で過去に同じようなトピックがないか検索してみてください。
固定ページ・投稿ページのプレビュー画面...
 
通知
すべてクリア

固定ページ・投稿ページのプレビュー画面が真っ白で表示できない。

11 投稿
3 ユーザー
3 Likes
117 表示
kdk4569
(@kdk4569)
投稿: 7
メンバー
Topic starter
 

1週間ぐらい前より「投稿記事」「固定ページ」編集時のプレビューを押すと真っ白な画面が表示されてプレビューできない
※ユーザーからは問題なく表示が出来ている

1.記事編集時に「新しいタブでプレビュー」
2.投稿一覧、固定ページ一覧の

編集 |  | ゴミ箱へ移動 | 表示

の表示ボタンをおしても同一現象が起こります。

 

トラブルを発見したキッカケ:

・ウイジェットの項目を追加した

・新記事追加

試みたこと

・キャッシュのクリア
→表示できない

・ウィジェット(サイドバー)の追加項目の削除、サイドバー項目の全削除
→表示できない

・他の人にログインしてもらいプレビュー検証
→表示できない

・他のテーマに変更→twenty Twenty-four ver1.1
→変更後はプレビューが可能に

・子テーマを無効にして、SWELLを有効化
→表示できない

確認項目
利用規約に同意します*, ガイドラインを読み、内容を把握しています*, よくある質問を先にチェック済みです*, 過去に同じようなトピックがないか検索済みです*, WordPress更新後、SWELLは最新版にしましたか?, Googleなどでも検索してみました, プラグインを停止しても同じことが起こることを確認しました, デフォルトテーマ等、他のテーマでも同じことが起こることを確認しました, 自分で追加したコードに問題がないかチェック済みです, サポート範囲外だということを理解しているが助けが欲しい(有料サポートしてくれる方を探したい)
問題が確認できるページのURL
利用中のSWELL本体のバージョン
2.10.0
利用中のPHPバージョン
8.1.22
OS
Windows
利用中のWordPressバージョン
6.5.3
利用中のサーバー会社
Xサーバー
ブラウザ
Chrome 125.0.6422.113
利用中のプラグイン一覧

Advanced Custom Fields (v.6.3.0)
All in One SEO (v.4.6.3)
BackWPup (v.4.0.4)
BBQ Firewall (v.20240306)
Code Snippets (v.3.6.5.1)
Contact Form 7 (v.5.9.5)
Customizer Export/Import (v.0.9.6)
XO Security (v.3.10.3)

 
投稿済 : 03/06/2024 12:40 pm
skillsharejp
(@skillsharejp)
投稿: 1028
SWELL高速化顧問
 
投稿者:: @kdk4569

1週間ぐらい前より「投稿記事」「固定ページ」編集時のプレビューを押すと真っ白な画面が表示されてプレビューできない

ここに解決のヒントがありそうです。何かサイト上で変更されましたか?

SWELLフォーラムはユーザーフォーラムのため、開発者以外の回答は全て任意です。当アカウントによる回答もボランティアのため、ヒントの提供に留まる場合があります。

ご依頼のご相談・お問い合わせ窓口
https://skillshare.biz/inquiry/

 
投稿済 : 03/06/2024 11:19 pm
kdk4569
(@kdk4569)
投稿: 7
メンバー
Topic starter
 

最初の投稿時にも記載をしておりますが、ウィジェットを追加しました。

ただ、その際に追加したウィジェットの項目は、その後すぐに削除をしておりますので、

現在はプレビュー画面にて不具合が起こる前と同じ状態です。

 

また、下記追記です。

同じPCにおいてもWordpressへログインしていない場合は、サイトを開くことが可能ですが、

Wordpressへログイン後(編集時)に、サイトを閲覧しようとすると画面が真っ白になってしまいます。

※プレビューも同様に。

Wordpressからログアウトすると通常にサイトが見れるようになります。

不思議なのが、Wordpressへログイン前にWEB上で閲覧していた記事(投稿)や固定ページは、

Wordpressログイン後にもプレビューできるのですが、それ以外の記事(投稿)や固定ページは真っ白になります。

※ちなみにですが、見れていた内容も再読み込み等行うと真っ白になります。

※サイトを閲覧せずにWordpressへログインするとトップページ含め全て真っ白です。

 

他のテーマに切り替えた際には、Wordpressへログイン前、ログイン後関係なく、

通常通りにプレビューができていますので、ウィジェットの項目でのミスやWordpressの不具合ではないと考えています。

 

よろしくお願いします。

 
投稿済 : 04/06/2024 10:01 am
skillsharejp
(@skillsharejp)
投稿: 1028
SWELL高速化顧問
 
  • ブラウザバージョンが古い
  • ブラウザキャッシュに問題がある

といった可能性はないですか?

私もSWELL使ってますがご相談の症状は一切発生したことがないので。なのでSWELL不具合というより、特定のサイトまたは特定の端末で発生するのかなと思っています。

単純な話、SWELL不具合として断定するとしたら全てのSWELL利用者が同じ症状を訴える必要があるので。

あとはサーバーのログを確認したりすると問題を特定しやすいかもしれません。

SWELLフォーラムはユーザーフォーラムのため、開発者以外の回答は全て任意です。当アカウントによる回答もボランティアのため、ヒントの提供に留まる場合があります。

ご依頼のご相談・お問い合わせ窓口
https://skillshare.biz/inquiry/

 
投稿済 : 04/06/2024 11:02 am
kdk4569
(@kdk4569)
投稿: 7
メンバー
Topic starter
 

ご返信ありがとうございます。

ブラウザは最新であり、ブラウザキャッシュやSWELLのキャッシュなどもクリアして試すなど問題ありません。

PC端末も1台だけではなく、他4台(合計5台)のPCで試しましたが、

いずれも同じ症状が起きるため、端末などにも問題はないかと考えています。

※5台いずれの端末も最新であり、キャッシュにも問題ありません。

 

サーバーのログにも特段、問題は見当たらずです・・・

プラグインの停止や子テーマからの切り替えなど、考えられる対応は基本的に行ったのですが、

他に可能性が考えられることや、対処法などあれば、ご教示いただきたいです。

 

よろしくお願いいたします。

 
投稿済 : 04/06/2024 12:18 pm
skillsharejp
(@skillsharejp)
投稿: 1028
SWELL高速化顧問
 

同じサーバーにテストサイトを作成して同バージョンのSWELLのみを有効化し、同じように操作したらどうなりますか?

SWELLフォーラムはユーザーフォーラムのため、開発者以外の回答は全て任意です。当アカウントによる回答もボランティアのため、ヒントの提供に留まる場合があります。

ご依頼のご相談・お問い合わせ窓口
https://skillshare.biz/inquiry/

 
投稿済 : 04/06/2024 1:24 pm
kdk4569
(@kdk4569)
投稿: 7
メンバー
Topic starter
 

お話いただいた通りに、同じサーバー上にテストサイトを作成し、同じバージョンのSWELLを有効化したところ、

こちらでは通常通りにプレビューすることができました。

Wordpressへログインしたあとでも問題なく動きました。

 

現在、現象が起きてしまっているものにつきましては、次回のアップデートが来たら直るみたいなことはあるのでしょうか??

 
投稿済 : 04/06/2024 2:29 pm
skillsharejp
(@skillsharejp)
投稿: 1028
SWELL高速化顧問
 
投稿者:: @kdk4569

現在、現象が起きてしまっているものにつきましては、次回のアップデートが来たら直るみたいなことはあるのでしょうか??

SWELLの問題であると認められない限り、修正がリリースされることはないと思います。

投稿者:: @kdk4569

お話いただいた通りに、同じサーバー上にテストサイトを作成し、同じバージョンのSWELLを有効化したところ、

こちらでは通常通りにプレビューすることができました。

Wordpressへログインしたあとでも問題なく動きました。

SWELLのみのサイトで正常な動作をする段階で不具合ではありません。なのでご自身のサイト特有の現象については今後も検証を続けて問題解決を図っていただくのがベストだと思います。

他の方からヒントをいただくのを待つか、どうしてもすぐ修正したいのであれば代行サービスを見つけて解決するしかないかな~と。

SWELLフォーラムはユーザーフォーラムのため、開発者以外の回答は全て任意です。当アカウントによる回答もボランティアのため、ヒントの提供に留まる場合があります。

ご依頼のご相談・お問い合わせ窓口
https://skillshare.biz/inquiry/

 
投稿済 : 04/06/2024 3:08 pm
kdk4569
(@kdk4569)
投稿: 7
メンバー
Topic starter
 

色々とご返信ありがとうございました。

承知しました。

プレビュー以外は問題なく使えておりますので、

様子を見ながら、改善できるよう対応していきたいと思います。

 
投稿済 : 05/06/2024 8:10 am
skillsharejp reacted
shiichan
(@shiichan)
投稿: 1
メンバー
 

@kdk4569 

私も同じような現象が発生しました。

私の場合、All in One SEO (v.4.6.3)が原因で、All in One SEO (v.4.6.2)にダウングレードするとプレビュー画面が表示さるようになりました。

最新版のAll in One SEO (v.4.6.4)でも改善されてなかったので、今はAll in One SEO (v.4.6.2)を継続して使っています。

お役に立てるかどうかわかりません。

 

【使っている環境】

wordpress 6.5.4

AdminColumns バージョン4.6.1
AkismetAnti-spam:SpamProtection バージョン5.3.2
AllinOneSEO バージョン4.6.2
BrokenLinkChecker バージョン2.2.4
CategoryOrderandTaxonomyTermsOrder バージョン1.8.2
CustomizerExport/Import バージョン0.9.6
DeMomentSomTresWordPressExportPostsWithImages バージョン20220825
EWWWImageOptimizer バージョン7.7.0
IndexNow バージョン1.0.3
Pochipp バージョン1.14.0
PochippPro バージョン1.9.0
RegenerateThumbnails バージョン3.1.6
SearchRegex バージョン3.0.8
ShowArticleMap バージョン0.8
TaxoPress バージョン3.21.0
WebSub(FKA.PubSubHubbub) バージョン3.2.1
WidgetImporter&Exporter バージョン1.6.1
WordPressPopularPosts バージョン6.4.2
WordPressインポートツール バージョン0.8.2
WPFastestCache バージョン1.2.7
WPMultibytePatch バージョン2.9
WPSitemapPage バージョン1.9.4
WP-PostViews バージョン1.77

 
投稿済 : 08/06/2024 7:23 am
skillsharejp reacted
kdk4569
(@kdk4569)
投稿: 7
メンバー
Topic starter
 

@shiichan 

ご返信ありがとうございます。

ご指摘いただいた通りに対応してみたところ、プレビューが表示できるようになりました。

大変助かりました。

ありがとうございます!

 
投稿済 : 10/06/2024 10:46 am
shiichan reacted
共有: