Discordコミュニティを作りました! 参加する

フォーラム

トピックを立てる前にチェック
  1. フォーラムガイドライン」に必ず目を通してください。
  2. バージョンアップデート後に表示がおかしくなった場合は、
    「SWELL設定」>「リセット」からキャッシュクリアを先にお試しください。
  3. フォーラム内検索で過去に同じようなトピックがないか検索してみてください。
メインビジュアルのブログパーツがiPh...
 
通知
すべてクリア

[解決済] メインビジュアルのブログパーツがiPhoneだけ表示されない

7 投稿
3 ユーザー
10 Likes
248 表示
syamoji1192
(@syamoji1192)
投稿: 6
メンバー
Topic starter
 

メインビジュアルに動画を設定し、ブログパーツでサイトロゴとテキストを表示させる設定をしましたが、iPhoneだけそのブログパーツ部分が表示されません。
PC、Androidスマホでは表示されていますが、iPhoneだけなぜか表示されないようです。

↓過去に似たような症状がトピックに上がっていましたが、

https://users.swell-theme.com/forum/swell-forum/%E3%83%A1%E3%82%A4%E3%83%B3%E3%83%93%E3%82%B8%E3%83%A5%E3%82%A2%E3%83%AB%E3%81%AB%E3%83%96%E3%83%AD%E3%82%B0%E3%83%91%E3%83%BC%E3%83%84%E3%81%A8%E3%83%9C%E3%82%BF%E3%83%B3%E3%81%8C%E5%8F%8D%E6%98%A0/

https://u.swell-theme.com/community/postid/5319/

上記質問を参考に設定を見直してみましたが、やはりiPhoneだけ表示されず。
解決策がわからなくなったので、どうか皆様のご意見をご教授いただけますと幸いです。

それでは、よろしくお願いいたします。

確認項目
利用規約に同意します*, ガイドラインを読み、内容を把握しています*, よくある質問を先にチェック済みです*, 過去に同じようなトピックがないか検索済みです*, WordPress更新後、SWELLは最新版にしましたか?, Googleなどでも検索してみました, プラグインを停止しても同じことが起こることを確認しました, デフォルトテーマ等、他のテーマでも同じことが起こることを確認しました, 自分で追加したコードに問題がないかチェック済みです, サポート範囲外だということを理解しているが助けが欲しい(有料サポートしてくれる方を探したい)
問題が確認できるページのURL
利用中のSWELL本体のバージョン
2.7.6.2
利用中のPHPバージョン
8.2.7
OS
iPhone
利用中のWordPressバージョン
6.2.2
利用中のサーバー会社
ロリポップ
ブラウザ
Safari
利用中のプラグイン一覧

Blocks Animation: CSS Animations for Gutenberg Blocks (v.2.2.0)
Combine Social Photos | Still BE (v.0.12.0)
Contact Form 7 (v.5.7.3)
LoftLoader (v.2.4.0)
SEO SIMPLE PACK (v.3.2.0)
XO Slider (v.3.4.1)

 
投稿済 : 24/06/2023 1:37 am
かんた
(@swell_mania)
投稿: 608
Https://webrent.xsrv.jp/
 

原因は分かりませんが、画像を1つとテキストだけの表示であればブログパーツを使わない方法もあります。

メインテキストとサブテキストは一部HTMLタグが使えるので、例えばメインテキスト部分に<IMG>タグで画像を表示させて、サブテキストに「遊ぶだけで残る...」のテキストを入力されるといった方法です。

main text

一般ユーザー
SWELL初心者のために、ブロックパターンライブラリーを運営しています。

 
投稿済 : 24/06/2023 5:46 pm
しらこ
(@96ssbike)
投稿: 842
メンバー
 

主要な部分は、かんたさんが代替案も含めて提示していただきましたが(かんたさんが提示されたのは、今取り入れている実装方法よりももっとメンテがしやすくて、簡易な方法だと思います)、かんたさんと同じく、サイトそのものを提示いただいた状態なだけでは、症状の原因の切り分けは、少し困難かと思います(その部分が、かんたさんがおっしゃる「原因は分かりませんが」の意味)。

その理由が、ユーザー自身が、少し複雑にカスタマイズされている点です。
たとえば、ローディングのプラグインや、CSSをカスタマイズされている部分のことです。
こういった部分を順番に取り除いていくことで、原因の切り分けが容易になると思います。

SWELLカスタマイズ向けの非公式サイトを作りました。何か見つかるかも?→ https://tecchan.jp/swell-tips/
上記以外のWordPress全般向けのナレッジはこちら→ https://tecchan.jp/
疲れたら癒やされてくださいにゃーん (ΦωΦ)

 
投稿済 : 24/06/2023 11:18 pm
syamoji1192
(@syamoji1192)
投稿: 6
メンバー
Topic starter
 

@swell_mania
返信遅くなり申し訳ありません!
それと解決策もありがとうございます!
この対処で出るようになりました!
多分ローディングのプラグインか、自前で入れた動画自動再生用のjavascriptが原因かと思われます。
とりあえず自前のjavascriptは消去して、かんたさんの方法で対処できました!
本当に助かりました!ありがとうございます!

 
投稿済 : 25/06/2023 8:57 am
しらこ and かんた reacted
syamoji1192
(@syamoji1192)
投稿: 6
メンバー
Topic starter
 

@96ssbike 
確かにおっしゃる通り、少し複雑化させてしまっているせいで何が原因か特定が難しくなっていました。
とりあえずかんたさんの方法で対処できましたので、取り急ぎご報告させていただきます。
今後の参考になりました。大変助かりました。
誠にありがとうございます!

 
投稿済 : 25/06/2023 8:59 am
しらこ reacted
かんた
(@swell_mania)
投稿: 608
Https://webrent.xsrv.jp/
 

解決して何よりです。

トピックを「解決済」になさってください。

 

しらこさんもフォローありがとうございました😁

一般ユーザー
SWELL初心者のために、ブロックパターンライブラリーを運営しています。

 
投稿済 : 25/06/2023 9:03 am
syamoji1192
(@syamoji1192)
投稿: 6
メンバー
Topic starter
 

@swell_mania 
はい!ありがとうございました!
それでは解決済みとさせていただだきます!
かんたさん、しらこさん、本当にありがとうございましたm(_ _)m

 
投稿済 : 25/06/2023 11:45 am
しらこ reacted
共有: