Discordコミュニティを作りました! 参加する

フォーラム

トピックを立てる前にチェック
  1. フォーラムガイドライン」に必ず目を通してください。
  2. バージョンアップデート後に表示がおかしくなった場合は、
    「SWELL設定」>「リセット」からキャッシュクリアを先にお試しください。
  3. フォーラム内検索で過去に同じようなトピックがないか検索してみてください。
メルマガ配信の推奨プラグインについて
 
通知
すべてクリア

メルマガ配信の推奨プラグインについて

7 投稿
4 ユーザー
1 Likes
1,025 表示
nijiiropokke
(@nijiiropokke)
投稿: 3
メンバー
Topic starter
 

最近SWELLに乗り換えた者です。

これまでMailPoetというプラグインでメルマガを配信していたのですが、このプラグインを有効化すると、SWELLで作った「投稿リスト」および「関連記事」のブロックが「このブロックでエラーが発生したためプレビューできません。」という表示になってしまいます。新規作成し直すと、途中まで作れるのですが、ブロックのタブを「Pickup」に切り替えた瞬間エラーになります。
MailPoetを無効化してキャッシュクリアするとエラーが解消されるので、このプラグインが原因というのは間違いないと思います。

そこで、Subscribe2という別のプラグインに変えてみたのですが、やはり「投稿リスト」および「関連記事」で同様の現象が起きます。正確には、こちらは新規作成は最後までできるのですが、一度更新してもう一度編集画面を開くとエラーになっています。やはりSubscribe2を無効化するとエラーが解消されます。

なお、このエラーは編集画面のみの現象で、サイト上では問題なく表示されています。しかし、かなり多くの箇所で使っているブロックのため、やはり不便なので、エラーの出ないメルマガプラグインを使いたいです。

そこで、SWELLと相性のいいメルマガ配信プラグインをご存知の方がいらっしゃったら教えていただきたいです。

もしくは、上記エラーが解決する方法がもしあれば教えていただけると大変ありがたいです。

どうぞよろしくお願い致します。

◆編集画面例

image

◆サイト( https://nijiiropokke.info/)

image
確認項目
利用規約に同意します*, ガイドラインを読み、内容を把握しています*, よくある質問を先にチェック済みです*, 過去に同じようなトピックがないか検索済みです*, WordPress更新後、SWELLは最新版にしましたか?, Googleなどでも検索してみました, 自分で追加したコードに問題がないかチェック済みです, サポート範囲外だということを理解しているが助けが欲しい(有料サポートしてくれる方を探したい)
問題が確認できるページのURL
利用中のSWELL本体のバージョン
2.7.0.1
利用中のPHPバージョン
7.4.30
OS
Windows
利用中のWordPressバージョン
6.1
利用中のサーバー会社
さくらレンタルサーバー
ブラウザ
Chrome
利用中のプラグイン一覧

BackWPup (v.3.10.0)
SAKURA RS WP SSL (v.1.4.0)
SEO SIMPLE PACK (v.3.0.0)
Subscribe2 (v.10.37)
Wordfence Security (v.7.7.1)
WPForms Lite (v.1.7.7.2)
WP Multibyte Patch (v.2.9)

This topic was modified 2年前 4回 by nijiiropokke
 
投稿済 : 04/11/2022 3:12 pm
skillsharejp
(@skillsharejp)
投稿: 1031
SWELL高速化顧問
 

SMTPやSendGrid等のサーバーを介さないメール配信、特にレンタルサーバーからのメール配信は到達率が低いです。他に思いつくのはJetpackです。あとは専用のメール配信サービスを使用するのが到達率を踏まえればおすすめです。

https://ja.jetpack.com/support/subscriptions/

SWELLフォーラムはユーザーフォーラムのため、開発者以外の回答は全て任意です。当アカウントによる回答もボランティアのため、ヒントの提供に留まる場合があります。

ご依頼のご相談・お問い合わせ窓口
https://skillshare.biz/inquiry/

 
投稿済 : 09/12/2022 6:28 pm
Tetsuaki Hamano
(@tetsuaki-hamano)
投稿: 19
メンバー
 

こんにちは。

こちらでも検証してみましたが、該当の症状は発生しませんでした。

  • SWELL Version: 2.7.1
  • PHP Version: 8.0.26
  • WordPress Version: 6.1.1
  • MailPoet (v.4.1.1)

おそらく、ブラウザコンソールに何かエラーメッセージが出ているはずですので、そちらのテキストのコピーもしくはスクリーンショットをいただけないでしょうか。

ブラウザコンソールの開き方は、このような記事が参考になると思います。

 

console
 
投稿済 : 09/12/2022 6:36 pm
skillsharejp reacted
nijiiropokke
(@nijiiropokke)
投稿: 3
メンバー
Topic starter
 

@skillsharejp ありがとうございます、参考にさせていただきます!

 
投稿済 : 10/12/2022 9:23 am
nijiiropokke
(@nijiiropokke)
投稿: 3
メンバー
Topic starter
 

@tetsuaki-hamano ありがとうございます!!

まずテーマの更新が入っていたので更新したのですが、「投稿リスト」はエラーが出るものと出ないものがあります…。

「関連記事」もエラーが出ています。

(なお、別の方にサーバのWAFの設定が悪さをしているかもと言われて確認しましたが、もともと無効でした)

ブラウザコンソールのエラーメッセージはこのようになっていました。

image

現在以下の状態で、 Tetsuaki様とはPHPのバージョンが異なるようです。アップデートしたほうがよいでしょうか?

バージョン情報

WordPress: 6.1.1
SWELL: 2.7.1.1
PHP: 7.4.33

有効化中のプラグイン一覧

BackWPup (v.4.0.0)
MailPoet (v.4.1.1)
SAKURA RS WP SSL (v.1.4.0)
SEO SIMPLE PACK (v.3.1.2)
Wordfence Security (v.7.8.0)
WPForms Lite (v.1.7.8)
WP Multibyte Patch (v.2.9)
 
投稿済 : 10/12/2022 9:29 am
了
 
(@loos_ryo)
投稿: 1248
メンバー Admin
 

もしかすると、メルマガ配信プラグインとは無関係で、REST API を停止するプラグインを入れてしまっているかもしれません。

SWELL開発者です。

 
投稿済 : 12/12/2022 3:46 pm
skillsharejp
(@skillsharejp)
投稿: 1031
SWELL高速化顧問
 

もしかすると、メルマガ配信プラグインとは無関係で、REST API を停止するプラグインを入れてしまっているかもしれません。

Wordfence Securityの設定が怪しいのが一点。もう一つはサーバーで制限されているのが一点。どちらもユーザー設定次第の範囲ですね。

 

SWELLフォーラムはユーザーフォーラムのため、開発者以外の回答は全て任意です。当アカウントによる回答もボランティアのため、ヒントの提供に留まる場合があります。

ご依頼のご相談・お問い合わせ窓口
https://skillshare.biz/inquiry/

 
投稿済 : 12/12/2022 4:01 pm
共有: